Some Quick Questions from a noob

Topics: Developer Thread, Support Request
Sep 3, 2008 at 7:14 PM
Greetings,

I've got my blog up and running http://www.bkriesel.com/; but, it has some small problems.  When I click on a blog entry I get a 404 error.  http://www.bkriesel.com/2008/08/26/Test.aspx

Also, when logged in when I attempt to delete an entry I get a Server Error in '/' Application. 

My hosting provider is WebHost4Life and I'm on IIS 7.  I think the change I had to make to the webconfig to make das blog work with IIS 7 might be the cause of these problems, but I'm kind of stumped so I'm not sure how to go about looking into fixing these little problems. 

I added to the webconfig

 <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
  </system.webServer>

Thanks,

Brian
Coordinator
Sep 3, 2008 at 9:55 PM
See this link: http://forums.iis.net/t/1150266.aspx (validateIntegratedModeConfiguration="false") apprantley this just turns off the errors, it does not stop the issue.

If your IIS7 site is setup in Integrated Mode it appears that the httpModules are not being seen in <system.web>.

While I am no expert on web.config and IIS7 I would try adding this:

<system.webServer>
  <httpModules>
   <add type="newtelligence.DasBlog.Web.Core.UrlMapperModule, newtelligence.DasBlog.Web.Core" name="UrlMapperModule"/>
   <add type="newtelligence.DasBlog.Web.Core.TitleMapperModule, newtelligence.DasBlog.Web.Core" name="TitleMapperModule"/>
   <add type="newtelligence.DasBlog.Web.Core.ProfileMapperModule, newtelligence.DasBlog.Web.Core" name="ProfileMapperModule"/>
   <add type="newtelligence.DasBlog.Web.Core.WebControls.ControlImageModule, newtelligence.DasBlog.Web.Core" name="ControlImageModule"/>
   <add type="blowery.Web.HttpCompress.HttpModule, blowery.web.HttpCompress" name="CompressionModule"/>
   <add type="newtelligence.DasBlog.Web.Core.IPBlackList, newtelligence.DasBlog.Web.Core" name="IPBlackList"/>
  </httpModules>
</system.webServer>

Luck
Tom
Sep 4, 2008 at 12:07 AM
Greetings,

I tried <system.webServer>  <httpModules> .... </httpModules> </system.webServer> and that only resulted in HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid. 

Then I attempted to create the config 
<system.webServer>  <modules> .... </modules> </system.webServer> like this which appears to be what http://forums.iis.net/t/1150266.aspx is recomending and I get this error

[ArgumentOutOfRangeException: Index and count must refer to a location within the string.
Parameter name: count]
System.String.Remove(Int32 startIndex, Int32 count) +0
blowery.Web.HttpCompress.HttpModule.CompressContent(Object sender, EventArgs e) +194
System.Web.SendResponseExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +203
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64

Thanks,
Brian

Sep 4, 2008 at 12:20 AM
Greetings,

Ok, I think I've got this fixed.  I removed the httpHandlers and httpModules section and created the <system.webServer>  <modules> .... </modules> </system.webServer> section. 

Thanks,
Brian


Coordinator
Sep 4, 2008 at 2:54 AM
Edited Sep 4, 2008 at 2:57 AM
OK, if you have any issues you may want to review the 14700 dasBlog release Paul included a web.config for this very issue, I forgot it was there :(

http://www.codeplex.com/dasBlog/SourceControl/FileView.aspx?itemId=260508&changeSetId=14700

Tom
Coordinator
Sep 19, 2008 at 6:04 AM
That's the right thing to have done. You coudl ALSO have done this:

%systemroot%\system32\inetsrv\APPCMD.EXE migrate config "Default Web Site/YourVdir"

On Wed, Sep 3, 2008 at 4:20 PM, bkriesel <notifications@codeplex.com> wrote:

From: bkriesel

Greetings,

Ok, I think I've got this fixed. I removed the httpHandlers and httpModules section and created the .... section.

Thanks,
Brian


Read the full discussion online.

To add a post to this discussion, reply to this email (dasBlog@discussions.codeplex.com)

To start a new discussion for this project, email dasBlog@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Scott Hanselman
http://www.hanselman.com