FreeTextBox has not been correctly installed

Topics: Support Request
Sep 8, 2008 at 7:33 PM

I'm getting this no matter whether the web.config is enabled or not. I know that .axd works on my hosting provider because other resources are downloading fine via the WebResource.axd resource. I've tried updating with the latest daily build as well to no effect. I've also updated the assembly reference new version in the web.config to match the latest FreeTextBox.dll version number.

This is the text shown in the FreeTextBox display (not including the +++'s):
++++++++++++++++++++++++++++++++++++++
FreeTextBox has not been correctly installed. To install FreeTextBox either:
(1) add a reference to FtbWebResource.axd in web.config:
<system.web>
<httpHandlers>
<add verb="GET"
path="FtbWebResource.axd"
type="FreeTextBoxControls.AssemblyResourceHandler, FreeTextBox" />
</httpHandlers>
</system.web>

(2) Save the FreeTextBox image and javascript files to a location on your website and set up FreeTextBox as follows
<FTB:FreeTextBox id="FreeTextBox1" SupportFolder="ftbfileslocation" JavaScriptLocation="ExternalFile" ButtonImagesLocation="ExternalFile" ToolbarImagesLocation="ExternalFile" ButtonImagesLocation="ExternalFile" runat="server" />
++++++++++++++++++++++++++++++++++++++

Any help will be greatly appreciated.

Coordinator
Sep 19, 2008 at 6:04 AM
If I have problems like this with FTB, I delete/rename the whole FTB folder *completely* and copy over a fresh one.

On Mon, Sep 8, 2008 at 11:33 AM, tsjensen <notifications@codeplex.com> wrote:

From: tsjensen

I'm getting this no matter whether the web.config is enabled or not. I know that .axd works on my hosting provider because other resources are downloading fine via the WebResource.axd resource. I've tried updating with the latest daily build as well to no effect. I've also updated the assembly reference new version in the web.config to match the latest FreeTextBox.dll version number.

This is the text shown in the FreeTextBox display (not including the +++'s):
++++++++++++++++++++++++++++++++++++++
FreeTextBox has not been correctly installed. To install FreeTextBox either:
(1) add a reference to FtbWebResource.axd in web.config:


<add verb="GET"
path="FtbWebResource.axd"
type="FreeTextBoxControls.AssemblyResourceHandler, FreeTextBox" />



(2) Save the FreeTextBox image and javascript files to a location on your website and set up FreeTextBox as follows

++++++++++++++++++++++++++++++++++++++

Any help will be greatly appreciated.

Read the full discussion online.

To add a post to this discussion, reply to this email (dasBlog@discussions.codeplex.com)

To start a new discussion for this project, email dasBlog@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Scott Hanselman
http://www.hanselman.com
Jun 24, 2009 at 12:08 AM

Scott,

Your suggestion solved the problem above for me.  You saved me a lot of time, I could've been chasing down this issue for quite some time!

Thanks,

Troy