Recommendations for upgrading from 1.8.5223.2 to 2.1?

Topics: Support Request
Sep 27, 2008 at 10:39 AM

Hi all,

I currently have dasBlog 1.8.5223.2 installed under ASP.NET 1.1; this is now a little long in the tooth so I'm hoping to upgrade to 2.1. However, 2.1 obviously requires ASP.NET 2.0. On the other hand, I've read that 1.8 won't run on 2.0 without modification. So I seem to be stuck with a chicken-and-egg scenario - whilst I want to upgrade from one working installation to another (both to avoid downtime and reduce the risk of irreparable catastrophe), I can't upgrade ASP.NET without knocking the site down unless I upgrade dasBlog first, and can't upgrade dasBlog without first upgrading to ASP.NET 2.0. Has anyone else done this? What would be the recommended procedure?

Would the only option be to first upgrade to 1.9.7 final, then upgrade ASP.NET, then upgrade again to 2.1?

Thanks in advance,

Ed

Coordinator
Oct 6, 2008 at 6:58 AM
If it were me, and it has been in the past, I'd just back up everything, upgrade ASP.NET then upgrade DasBlog. Should "just work." Just make sure you use a diff tool to compare your existing web.config with the new one and move in the new lines.

On Sat, Sep 27, 2008 at 2:39 AM, trogdor <notifications@codeplex.com> wrote:

From: trogdor

Hi all,

I currently have dasBlog 1.8.5223.2 installed under ASP.NET 1.1; this is now a little long in the tooth so I'm hoping to upgrade to 2.1. However, 2.1 obviously requires ASP.NET 2.0. On the other hand, I've read that 1.8 won't run on 2.0 without modification. So I seem to be stuck with a chicken-and-egg scenario - whilst I want to upgrade from one working installation to another (both to avoid downtime and reduce the risk of irreparable catastrophe), I can't upgrade ASP.NET without knocking the site down unless I upgrade dasBlog first, and can't upgrade dasBlog without first upgrading to ASP.NET 2.0. Has anyone else done this? What would be the recommended procedure?

Would the only option be to first upgrade to 1.9.7 final, then upgrade ASP.NET, then upgrade again to 2.1?

Thanks in advance,

Ed

Read the full discussion online.

To add a post to this discussion, reply to this email (dasBlog@discussions.codeplex.com)

To start a new discussion for this project, email dasBlog@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Scott Hanselman
http://www.hanselman.com