configuration errors after godaddy installation NEW PROBLEM

Topics: Support Request
Oct 1, 2008 at 1:12 AM
Hi there,

I have installed dasblog on my shared server on godaddy, however, I am getting the following error message when trying to access the application... Godadday takes forever to respond and I hate spending money calling them.

Server technologies: WINDOWS, ASP 1.0, ASP.NET 2.0, FRONTPAGE 0, MYSQL 4.0.27, 4.1, 5.0, MSSQL 2000, 2005

Thanks in advance for your help.

 

Server Error in '/' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
Developer
Oct 1, 2008 at 10:22 AM
The information you have posted is not enough to help debug your problem.  The error basically says "something bad happened, but unless you change your web.config, or use a browser on your shared server to view the page, I can't tell you about it".  I would suggest you edit your dasBlog web.config as described in the error message (i.e. set customErrors mode="off").  Then you will be able to get the actual error information from you local browser and post it back on the group (or read it and fix it yourself ;).




Oct 1, 2008 at 5:04 PM
It is already set to "off".  I also tried to change to the second modification above with a redirect to my custom error page and get the same results.  I finally received an email from godaddy this morning and they have referred to their "advanced techinical support team." to resolve your issue quickly and completely"  Oy ve... I cannot even get to the admin page of the application.  So I wait... 
Oct 1, 2008 at 5:16 PM
Edited Oct 1, 2008 at 5:37 PM
Well, I feel better, I noticed that the web.config file had become webconfig.bak so I copied a new copy of the web.config file (even though godaddy installed application on my site, I downloaded the 2.1 version) and now have the trust level issue which I believe only godaddy can resolve.   Here is the error and the way it is configured in the web.config file:

Line 71: </system.diagnostics>
Line 72: <system.web>
Line 73: <trust level="Medium" originUrl=".*" />  
Line 74:
Line 75: <!--  level="[Full|High|Medium|Low|Minimal]" -->
Source File: d:\hosting\canda\dasblog\web.config    Line: 73



This configuration section cannot be used at this path.  This happens when the site administrator has 
locked access to this section using <LOCATION allowOverride="false">
from an inherited configuration file. (d:\hosting\canda\dasblog\web.config line 73)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.
This error can be caused by a virtual directory not being configured as an application in IIS.
(d:\hosting\canda\dasblog\web.config line 103)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.
This error can be caused by a virtual directory not being configured as an application in IIS.
(d:\hosting\canda\dasblog\web.config line 130)


here is what is actually in the web.config file:

<system.web>
  <trust level="Medium" originUrl=".*" />  What should the wildcard be?

  <!--  level="[Full|High|Medium|Low|Minimal]" -->
  <!-- <trust level="High" originUrl=""/>  -->

And so I wait some more...

Developer
Oct 1, 2008 at 8:04 PM
Take out the trust tag completely.

Looks like go daddy has it configured so you can't specify that tag at all.

Is dasBlog installed into a subdirectory? The second two errors sound like you need to have that directory configured as an application.


Oct 1, 2008 at 11:09 PM
Thanks, Tony...

I removed that and am back to the "custom errors" dialog as above. 

It is installed by godaddy into it's own folder with what looks like the same file structure as what I downloaded with one exception; the root directory is 'dasblog' vs. 'dasblogce'

tc
Oct 4, 2008 at 8:25 AM

Well, I finally heard back from godaddy this am.  it is apparently my frontpage extensions.  acchhh!  Thanks for trying!

 

tc

Oct 4, 2008 at 9:01 PM
Can anyone tell me if I am fighting a futile battle trying to get dasblog to work with my website published in frontpage on godaddy?  I am at my wits end.

tc
Developer
Oct 4, 2008 at 9:30 PM
Why are you using Frontpage in the first place? Does godaddy not let you FTP files directly to your domain wwwroot directory? DasBlog will work pretty much with just an "xcopy" installation.

On Sat, Oct 4, 2008 at 4:02 PM, ktc <notifications@codeplex.com> wrote:

From: ktc

Can anyone tell me if I am fighting a futile battle trying to get dasblog to work with my website published in frontpage on godaddy? I am at my wits end.

tc

Read the full discussion online.

To add a post to this discussion, reply to this email (dasBlog@discussions.codeplex.com)

To start a new discussion for this project, email dasBlog@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
-------------------------------------------
Nicholas Schweitzer
nick@nickschweitzer.net

The World According to Nick
http://www.nickschweitzer.net

The Coding Monkey
http://www.thecodingmonkey.net
-------------------------------------------
Oct 23, 2008 at 2:50 PM
Has anyone figured out a solution to this problem?  I have a virtual dedicated server with Go Daddy, I've set all of the appropriate permissions on the folders and even went into the plesk manager to verify the trust on ASP.NET was set to full.   I cannot modify settings, nor can I add content..  I am ready to throw the server out the F- window.

I can use DasBlog on my local server in my office with has a ddicated Static IP - NO PROBLEM.  It takes me about 5 mins to set it up and get it working here. 
But I want to host my blogs using the godaddy server.   Is this going to be an exercise in futility? 

There should be detailed notes about how to setup on Godaddy. 

Oct 23, 2008 at 9:33 PM
Unfortunately, my issue ultimately was because I was publishing with FrontPage.  DasBlog and FrontPage do not like each other.  Good Luck!

tc
Nov 13, 2008 at 2:47 PM
I am on a shared environment with GoDaddy so I can't say what exactly to do about the trust level on a virtual server. I setup my dasBlog site back in May. I removed the trust level code from my web.config, setup my folder access through my control panel, and uploaded the site via FTP. It wasn't hard to setup once I figured out the trust level issue.

kibbs2008, have you tried removing the trust level to see if that helps?

-----
Jason Friend
jasonfriend.com
blog@jasonfriend.com

"Close the Gap!"
Nov 13, 2008 at 3:53 PM
I tried everything you mentioned. I removed the trust level from the web config, I made sure that the trust was appropriate in the plesk control panel, even fiddled with it a few times between low, medium and full. Went directly to the folders and set the permissions and security to Network Service (Still would not allow configuration changes to the blog nor would it allow posts to be made or deleted.)

The ONLY way I was able to do this, (and I'm not too happy about it), is to set the permission levels for "Everyone" allowing for write.

I love the blog platform, but its a little too clunky for my local web server. It runs well on godaddy, but I still havent figured out a way around that issue without setting permissions to "everyone"

Thanks for the heads up though.


-------- Original Message --------
Subject: Re: configuration errors after godaddy installation NEW
PROBLEM [dasBlog:36770]
From: jiff
Date: Thu, November 13, 2008 8:47 am
To: kcurran@journeyeast.org

#wmMessage {font-family: Verdana; font-size: 0.75em;} #wmMessage #ThreadNotificationFooter {border-top: 1px solid #ccc; color: gray;} #wmMessage #ThreadNotificationPostBody {Margin-Bottom: 2em;} #wmMessage {font-family: Verdana; font-size: 0.75em;} #wmMessage #ThreadNotificationFooter {color: gray; border-top: 1px solid #ccc;} #wmMessage #ThreadNotificationPostBody {Margin-Bottom: 2em;}
From: jiff
I am on a shared environment with GoDaddy so I can't say what exactly to do about the trust level on a virtual server. I setup my dasBlog site back in May. I removed the trust level code from my web.config, setup my folder access through my control panel, and uploaded the site via FTP. It wasn't hard to setup once I figured out the trust level issue.

kibbs2008, have you tried removing the trust level to see if that helps?

-----
Jason Friend
jasonfriend.com
blog@jasonfriend.com

"Close the Gap!"