Can't get past initial login on new install

Topics: Support Request
Aug 7, 2012 at 12:53 AM
Edited Aug 7, 2012 at 1:20 AM

I just installed dasblog on my website. It appears to be running, but when I try to login as the admin the loging seems to succeed, but I get the following error message:

 An error has been encountered while processing the page. We have logged the error condition and are working to correct the problem. We apologize for any inconvenience.

 Any hints on where I should look to solve the problem?

Looking in the log file, I see the following:

l2 time 2012-08-07T01:14:19 code 5001 message <span>Audit: SecuritySuccess Login with username blogadmin from 198.143.32.2</span>
l2 time 2012-08-07T01:14:19 code 1 message <span>Error:<br/>System.Web.HttpException (0x80004005): The application is configured to issue secure cookies. These cookies require the browser to issue the request over SSL (https protocol). However, the current request is not over SSL.
<br />  

But when I configure IIS to use SSL for the blog application, I get a 403 error on the browser trying to get to the login page:

403 - Forbidden: Access is denied.

You do not have permission to view this directory or page using the credentials that you supplied.

 

 


Coordinator
Aug 7, 2012 at 3:08 AM
Can you get to the log files in the log directory, that should give
you a clue what's wrong.

Also, where is dasBlog hosted? We've had numerous issues with godaddy
hosting and have not been able to resolve that.

Paul

On Mon, Aug 6, 2012 at 5:53 PM, [email removed] wrote:
> From: evadpurple
>
> I just installed dasblog on my website. It appears to be running, but when I
> try to login as the admin the loging seems to succeed, but I get the
> following error message:
>
> An error has been encountered while processing the page. We have logged the
> error condition and are working to correct the problem. We apologize for any
> inconvenience.
>
> Any hints on where I should look to solve the problem?
>
> Thanks
>
>
>
> 
>
> Read the full discussion online.
>
> To add a post to this discussion, reply to this email
> ([email removed])
>
> To start a new discussion for this project, email
> [email removed]
>
> You are receiving this email because you subscribed to this discussion on
> CodePlex. You can unsubscribe or change your settings on codePlex.com.
>
> Please note: Images and attachments will be removed from emails. Any posts
> to this discussion will also be available online at codeplex.com
Aug 7, 2012 at 3:26 AM

Paul,

This is being host on a server on AWS, so I have pretty much full control of the server, access to IIS manager, etc.

I've added more information in the text - here's the log info again:

Looking in the log file, I see the following:

l2 time 2012-08-07T01:14:19 code 5001 message <span>Audit: SecuritySuccess Login with username blogadmin from 198.143.32.2</span>
l2 time 2012-08-07T01:14:19 code 1 message <span>Error:<br/>System.Web.HttpException (0x80004005): The application is configured to issue secure cookies. These cookies require the browser to issue the request over SSL (https protocol). However, the current request is not over SSL.
<br />

But when I configure IIS to use SSL for the blog application, I get a 403 error on the browser trying to get to the login page:

403 - Forbidden: Access is denied.

You do not have permission to view this directory or page using the credentials that you supplied.

 

 Thanks

Coordinator
Aug 8, 2012 at 2:45 AM
This sounds like a configuration issue with IIS.. I really don't have
enough experience to help you troubleshoot this. One thing I would try
is if you can open an html file from the root of your website?

Thanks, Paul

On Mon, Aug 6, 2012 at 8:26 PM, [email removed] wrote:
> From: evadpurple
>
> Paul,
>
> This is being host on a server on AWS, so I have pretty much full control of
> the server, access to IIS manager, etc.
>
> I've added more information in the text - here's the log info again:
>
> Looking in the log file, I see the following:
>
> l2 time 2012-08-07T01:14:19 code 5001 message Audit: SecuritySuccess
> Login with username blogadmin from 198.143.32.2

> l2 time 2012-08-07T01:14:19 code 1 message
> Error:
System.Web.HttpException (0x80004005): The application is
> configured to issue secure cookies. These cookies require the browser to
> issue the request over SSL (https protocol). However, the current request is
> not over SSL.
>

>
> But when I configure IIS to use SSL for the blog application, I get a 403
> error on the browser trying to get to the login page:
>
> 403 - Forbidden: Access is denied.
>
> You do not have permission to view this directory or page using the
> credentials that you supplied.
>
>
>
> Thanks
>
> Read the full discussion online.
>
> To add a post to this discussion, reply to this email
> ([email removed])
>
> To start a new discussion for this project, email
> [email removed]
>
> You are receiving this email because you subscribed to this discussion on
> CodePlex. You can unsubscribe or change your settings on codePlex.com.
>
> Please note: Images and attachments will be removed from emails. Any posts
> to this discussion will also be available online at codeplex.com
Aug 8, 2012 at 4:10 AM

Paul,

I can get to an html page at the root directory of my website - over both http and https. I have a larger site that does a bunch of stuff, dasblog would just be the blog portion of my website.

Is there a way to configure dasblog to only use https for any access to the blog app?

Dave