This project is read-only.

dasBlog 2.11 release pending... Help needed...

Topics: Developer Thread, Information Provided, Suggestion, Support Request
Sep 4, 2008 at 3:25 AM
Edited Sep 4, 2008 at 3:33 AM

Ok folks I am hearing a need to release 2.11 or do we want to call it 2.2, lots of new features along with a lot of bug fixes.

I agree that we are about ready, and I can make those simple release code updates (documents etc., but I don't really have the time for the full release testing that I think the product deserves.

So I am asking for some help.

I have been releasing daily builds all along and do some testing as I go, but the following major changes need confirmation by other than the author or I since my testing is static, not a real blog site test.

  •  Resolved Theme loading issue; (missing Mobile Theme crashed system for mobile browsers) [Tested OK], you can see this crash at dasBlog.info with a mobile phone...
  • Added check to delete entry method: only admin or author is allowed to delete; (WLW editing allowed contributor to delete admin posts) [Not tested]
  •   Added OPENID identifier editbox to user edit page. And some cleanup of the sitesecurity classes; (extensive OPENID for comments support added) [Not tested]
  •  web.config for use in IIS7 Integrated mode; (sample file for IIS7 hosting in default Integrated mode, document in release) [Not tested]
  •  fixed live comment preview bug;(The last allowed tag was not working correctly in the live preview) [Tested OK]
  •  Adding support for themed 404 pages; (optional feature) [Not tested]
  •  fixed bug that caused IsDaylightSavingTime to always return false, resulting in comments always being off by one hour [Not tested]
  •  Added configuration page options for OPENID comments and admin, and updated site.config file; (version upgrades should take this into consideration) [Partial Test]
  •  Update to resolve Utils class defined twice; this also resolved the third party macro not being supported, which was unintentionally introduce in 2.1 [Tested OK for some third party macros, should work for prior working macros]
  •  Blog Stats macro not working; [Not Tested]  

So let me know if you have implemented a daily build and have tested one of these new features or bug fixes.

If I get an adequate response I will release 2.11 or 2.2 this weekend, it’s in your hands.

Thanks
Tom
 

Sep 4, 2008 at 5:13 AM
Hi Tom

+1 for 2.2

Also - is there any chance we could include the Older Posts DrawPostPagingPrevious(), Newer Posts DrawPostPagingNext() macro options in the default dasBlog theme?  I'd at least like to be able to test that this feature is working in each dasBlog release.

Will also take the daily build and try to give you some testing feedback before the weekend if I can.

Regards,

Tony
Sep 4, 2008 at 5:33 AM
Also OpenID will not work in medium trust. Maybe there should be a note or comment in the Web.config concerning this? I think Scott created a medium trust override setting for outbound server requests - but I'm having trouble finding this (and assumes that the hosting provider allows overrides either way).$0$0$0$0Webhost4Life who have previously always allowed full trust - have implemented a new feature called Security Guard - which sets the trust level of the site - and it caught my OpenID requests. However all that was required in this case was changing the security guard setting from 'strong' to 'medium' in the WH4L control panel.$0
Sep 4, 2008 at 2:10 PM
Hi Tom,

I just tested the following item:

Added check to delete entry method: only admin or author is allowed to delete; (WLW editing allowed contributor to delete admin posts) [Not tested]

It worked for me. When I logged in as a contrib and tried to delete one of the existing posts, via Live Writer, I got an error dialog in WLW saying "Current user is not allowed to delete post" (or something close to that).

Ben
Sep 7, 2008 at 9:12 PM
I just sync'ed to the HEAD and deployed to my blog. Everything is working great so far. and OpenID works fantastically!
Sep 19, 2008 at 6:04 AM
Really? I run in Medium trust and I'm using OpenID...hm...maybe I have WebPermissions allowed...

On Wed, Sep 3, 2008 at 9:33 PM, Abouch <notifications@codeplex.com> wrote:

From: Abouch

Also OpenID will not work in medium trust. Maybe there should be a note or comment in the Web.config concerning this? I think Scott created a medium trust override setting for outbound server requests - but I'm having trouble finding this (and assumes that the hosting provider allows overrides either way).$0$0$0$0Webhost4Life who have previously always allowed full trust - have implemented a new feature called Security Guard - which sets the trust level of the site - and it caught my OpenID requests. However all that was required in this case was changing the security guard setting from 'strong' to 'medium' in the WH4L control panel.$0

Read the full discussion online.

To add a post to this discussion, reply to this email (dasBlog@discussions.codeplex.com)

To start a new discussion for this project, email dasBlog@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
Scott Hanselman
http://www.hanselman.com