This project is read-only.

dasBlog New User

Topics: Support Request
Dec 4, 2008 at 9:36 PM
Hi All,

I've just installed dasBlog in a Windows server hosted site using GoDaddy. Pretty smooth installation. Looks and works great! Using Dreamweaver CS4 as an editor and Contribute CS3 as another way to post quickly.

Been reading all that I can find (searching the discontinued forum, etc.), trying to learn how to customize here and there. I'm stumped by a couple of these: (1) if I use some themes (for example, dasBlog theme), I can't figure out how to change the way the title displays when hyperlinked at screen top. Although I have configured the title as eLearningBlog, in this, and some of the other themes, it displays as all upper case. Can't figure out if there is any file that I can open in DW to stop the changing to upper case. (2) If Comments are configured to allow some/all HTML that are checked, the comment screen seems to display these items in a string. Only way I've found to prevent that is to check 'do not use html' in the comments (not too sure what using or not using html does, but suspect it has to do with tags and promoting the site-what I am was looking for was a way to allow the commenter to add hyperlinked referrals to useful web pages. Haven't figured that out, yet.)

Any suggestions, leads would be appreciated. I'm not very skilled at this, but eager to learn. I'm on a steep learning curve.

dasBlog is brilliant!

Kind Regards,

Dec 5, 2008 at 12:25 AM

Hi saratogacoah

The answer to your issue #1 question is easier than you might think.

The theme file "homeTemplate.blogtemplate" in each theme directory has a macro referenced called %siteNameLink%, the results of this macro reads your site configuration setting for "the site name". The format of this text is controlled by CSS in the themes CSS file, that file name is different for each theme. For example for the dasBlog theme the CSS file is dasBlog.css and the following css controls the layout.

.siteName, .siteName a, .siteName a:visited, .siteName a:hover, .siteName a:active, .siteName a:link {
 font-size: 1.5em;
 font-weight: normal;
 font-family: Georgia;
 letter-spacing: .2em;
 text-decoration: none;
 text-transform: uppercase;

The key is the above text-transform element.

Your can find documentation on the various macros exposed in the themes here:

A pretty good tutorial on how themes work and how you can modify them can be found here:

About CSS, you can find all you ever wanted to know about CSS on the web.

About your #2 issue, I am not sure I understand your problem. If you turn on html in your comments, and everything is working correctly then the commenter’s should be able to create comments with the available html tags, if they understand the manual use of the html tags, hyper linking is not supported, that would just be a spam magnetic, trust me you don't want that kind of action. The comment text field does not support a rich text edit function, the html tag options are for those that want to craft a html based text response.


Dec 5, 2008 at 12:29 AM
P.S to the above.

While you certainly can use the Dreamweaver editor on the dasBlog text files, its way over kill.

I personally love notepad++, and for blog posting I don't think you can beat Windows Live Writer (WLW) 

But each to his own.

Dec 5, 2008 at 12:59 AM
Edited Dec 5, 2008 at 1:21 AM

Hi Tom,

Thanks for your reply.

(1) I'll take a look at the theme's CSS. I suspect eliminating the entry "text-transform: uppercase;" would leave the original format (eLearningBlog instead of ELEARNINGBLOG). Hopefully.

(2) What is happening re: #2 is that a string appears at the bottom of the comment box (visible to any commenter) detailing the checked html items that are configured. So, if I check all items, I and the viewer see:

Comment (Some html is allowed: a@href@title, b, blockquote@cite, em, i, strike, strong, sub, sup, u) where the @ means "attribute." For example, you can use <a href="" title=""> or <blockquote cite="Scott">.

I can eliminate all of this by unchecking the "Allow HTML in comments." If I want to keep HTML in comments checked and select some or all items, is there any way to stop that string from displaying? 

(Thanks for your thoughts about DW. I just started using it, having happily used FrontPage 2003 for years. I have some other site tasks for which DW may be a good choice. I'm also a fan and regular user of Notepad, a very useful tool.)

 Any suggestions about where to look to get rid of that string?

Kind Regards,






Dec 5, 2008 at 1:27 AM
OK I understand now.

The current comment view system does not have the option to turn off the "html available text prompts".

You could create a custom version of dasBlog by editing these files/areas and recompiling the application.

Line 108 :     //Setup the Live Comment Preview with an allowed tags array "'a', 'b', 'p', 'strong', 'blockquote', 'i', 'em', 'u', 'strike', 'sup', 'sub', 'code'"
Line 109 :     Page.ClientScript.RegisterClientScriptBlock(this.GetType(),"allowedHtmlTags",String.Format(@"
Line 111 :      var allowedHtmlTags = [{0}];
Line 220 :              // only show the openid option when allowed in the config
Line 393 :          // if we allow tags, use the allowed tags, otherwise use an empty array
Line 394 :          ValidTagCollection allowedTags = (requestPage.SiteConfig.CommentsAllowHtml ? requestPage.SiteConfig.AllowedTags : new ValidTagCollection(null));
Line 489 :             string filteredText = SiteUtilities.FilterHtml(comment, allowedTags);

You could also submit this as a feature request for version 2.3.

Dec 5, 2008 at 1:55 AM
Thanks again, Tom

I was able, in the meanwhile, to place that text transform line of code as: /*text-transform: uppercase;*/ (there if ever I need it again). 

Regarding your most recent posting: maybe a next version (2.3) request? 

I appreciate your help.

Kind Regards,