This project is read-only.

Upgraded dasBlog, FTB now gives plain text box, not HTML editor

Topics: Support Request
Dec 8, 2008 at 11:47 PM

I upgraded to FireFox 3.0.4 earlier today. I just tried to make my first blog post since upgrading, and found that FTB wasn't working anymore. Weird things were happening, like all the text being lost when clicking from the Design tab to the HTML tab and so on.

I decided to upgrade dasBlog, as I was using an old version anyway. I downloaded the latest version, upgraded it and tried again.

Now when I try to write a blog post, I get a plain text box (actually a textarea in HTML terms), and no HTML editor.

I have checked my installation over and again, but can't see what's wrong. I deleted the whole ftb folder and copied it again, but no change.

The version of FreeTextBox.dll is, and my web.config file contains the following lines...

                <assemblyIdentity name="FreeTextBox" publicKeyToken="5962a4e684a48b87" culture="neutral"/>
                <bindingRedirect oldVersion="3.0.5000.0-" newVersion=""/>

Anyone any ideas as to what's going wrong?


Dec 9, 2008 at 12:18 AM
Edited Dec 9, 2008 at 1:52 AM
Me again,

Just realised that this isn't the only problem. When I click on the little calendar icon to choose the date for the post, I get a message box pop up with the message "Unable to find the required BDPLite JavaScript Library" and no calendar pops down. Don't know if these are related.

I also tried this in IE6 and had the same problems, so it's definitely a dasBlog issue, not a browser one.

I created a new folder, and copied the files from the dasBlog zip archive. All I changed was the Root setting in site.config so that it pointed at the right site. I logged in, clicked to add a new entry, and got the same textarea instead of the FTB editor. The calendar control worked now.

Anyone any ideas? I have no idea why this isn't working. I have now tried a completely fresh installation, and got the same problem. Thanks for any help
Dec 10, 2008 at 12:15 AM
It appears that the version of Freetextbox ( is not working in Firefox(version: 3.0.4).

You can manually upgrade to a later version of Freetextbox and update the version info in the Web.config, that should be a quick fix, we will have make sure that dasBlog 2.3 has a new FTB for the real final fix.

In the meantime, I would suggest Window Live Writer (WLW), I think most of us contributors would never discover this issue, as we have really sort of stopped using FTB for WLW and other remote solutions.

Dec 10, 2008 at 10:07 AM
Edited Dec 10, 2008 at 10:39 AM
Hello Tom,

Thanks for the reply.

Can't use WLW as I run Windows Server, and WLW doesn't run on that.

I tried upgrading to the latest version of FTB, but it didn't help. I downloaded 3.2.0 and added the DLL to the bin folder. I tried various combinations of changing the lines in web.config, as well as removing them altogether. I also tried renaming the ftb folder, as the newer versions of FTB have all the support files in the DLL.

However, none of this works. I still get a textarea instead of the HTML editor. I confirmed that FTB works fine in FireFox, so that isn't the problem.

Any ideas how I get FTB to work with dasBlog?

Thanks again,
Dec 11, 2008 at 2:20 AM
About WLW on Windows server, the installer for some silly reason won't run on Server 2003 or even 2008, nor on XP x64 (but it does on Vista x64 even if the installer claims otherwise).

Solution is to run the installer on a compatible PC, let it extract the MSI to your temp folder, then run the MSI on your computer (Server), it'll install just fine then.

As to the real issue of FTB on Firefox with your dasBlog, I have not tested this combination, I am not a FireFox user, so I took your word that this is an issue.
And since I googled and found about a dozen other people that said that FTB does not work with FireFox 3.0 I took your issue at face value.

I suspose that your dasBlog configuration FTB does work when you call it from IE or FF 2.0??

Also when you upgraded to FTB 3.2 did you try your configuration with any other the other browsers???

I will download FireFox and confirm some of my sites status and get back with you.


Dec 11, 2008 at 2:29 AM
I have just tested FireFox 3.04 with a couple of my dasBlog 2.2 sites, and they work fine with the FTB.

I have no clue as to why FTB does not work for you, but I really would move to WLW.

Dec 11, 2008 at 11:12 AM

Thanks for the reply. I'm going to give WLW a go. Trouble is, I just tried installing it on an XP box, and it's giving me all sorts of errors about needing to update the system. Any idea how to work out what updates will be needed to the server to get it to install?

Anyway, regarding FTB and dasBlog, I mentioned in a previous post that this is not a FireFox issue. I thought it was when I first struck the problem, but it became clear soon after that it's not.

As I said, I have downloaded the latest version of FTB, and it works fine in FF. The only problem is when I try to use it from dasBlog.

I'd really like to get it working from dasBlog, as I often want to blog when I'm not at home or in the office. Using WLW will only help for my own machines, not other people's.

Any idea how I would find out why it's not working?

Thanks again,
Dec 11, 2008 at 12:00 PM
Edited Dec 11, 2008 at 12:02 PM
Quick update. After a short Google, I found a link that might be useful. Here is a page that has a link to a download for the MSI file itself, saving you the bother of trying to find it in your temp folder. I downloaded and double-clicked this, got a progress bar for a few seconds, and then... nothing. I tried it a few times, and concluded that it didn't work. Ho hum.

I then decided to check the Application log, to see if it had left any message. To my surprise, it seemed that the install HAD worked, just very quickly, and with absolutely no indication of success.

I looked on the Programs menu, and there it was. Works a treat too! Unlike FTB, WLW actually produces valid (X)HTML!

Hope this is useful to someone.

However, this still leaves me with the question of why FTB doesn't work with dasBlog. I would still like to get that fixed.